RSS toujours "non-lus"

Vous avez une question sur le fonctionnement du site ? Un problème dans votre collection ? C'est ici que vous devez poser vos questions.

Modérateur : Correcteurs

Piscenois
ascète
Messages : 2
Enregistré le : dim. janv. 17, 2010 21:24

RSS toujours "non-lus"

Messagepar Piscenois » mar. août 16, 2016 17:05

Bonjour,

Je suis abonné à votre flux d'information. Mon agrégateur, Netvibes, marque toujours vos actualités comme non-lues.
Après inspection du flux il semblerait qu'il manque une date dans chaque news.
Selon la norme atom :
atom:feed elements MUST contain exactly one atom:updated element.


Pouvez-vous faire le nécessaire SVP ?

Merci :oops:

Avatar du membre
Chninkel
Administrateur
Messages : 2266
Enregistré le : mar. sept. 13, 2005 21:04
Localisation : Gelbique

Messagepar Chninkel » mer. août 17, 2016 19:10

Bonjour,

les flux sont en RSS, pas en Atom (même si on y trouve un link de type atom), est-ce qu'ajouter un tag <pubDate> par news fonctionnerait ?

Ou bien est-ce que Netvibes identifie le flux RSS comme de l'Atom (peut-être à cause du link) ?
Inventaire BD | Mes BD

"Allez, en vous remerciant, bonsoir !"

Piscenois
ascète
Messages : 2
Enregistré le : dim. janv. 17, 2010 21:24

Messagepar Piscenois » mar. août 23, 2016 17:04

Bonjour,

Il semblerait que la balise adéquate soit

Code : Tout sélectionner

<pubDate>Sat, 21 Aug 2004 19:30:00 GMT</pubDate>


Je l'ai trouvée en inspectant mes autres flux qui fonctionnent correctement.

Cordialement.